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Introduction 3

1. Introduction

This document is a basic guide for configuring a new Patapsco LanBand. A full User Manual for configuring all settings on the unit is supplied on the
DbManager Installation Disk. Patapsco offers an optional Pre-Configuration Service and optional Telephone Support Agreements at minimal cost.
Information on these options can be found in the Support document on the DbManager installation disk.

1.1. Transition Networks - Patapsco

Patapsco LanBand products allow the delivery of synchronous ISDN services across Local Area Networks. The product range covers both ISDN PRI and BRI
applications. ISDN Voice, data and video services are managed and delivered across a LAN with connection to outside PSTN services.

1.2. Safety warnings

L
- A Caution: Danger of electric shock. The device may be connected to mains voltages. Switch to power-off state before
working on the device.

-

=) A\ Cqytion: Danger of electrostatic discharge. Electronic components are sensitive fo electrostatic discharges that might
damage the device. Protect the device from electrostatic discharges by wearing an electrostatic wristband.

: A\ Cqution: Interruption of data transmission. Data transmission will be inferrupted during any work on the transmission
line and/or deactivation of the power supply. Make sure that that any work will only be carried out on inactive lines
(without data transmission) or during quiet times to reduce interference to live systems.

- Caution: Danger of damage to devices or service interruption. Access by unauthorized third persons may cause damage
to devices and/or inferrupt services. Make sure that subracks are only installed in lockable locations.

+ A Cqution: Danger of overvoltage. During faults, dangerous unprotected voltages may be present. Ensure sufficient
grounding of the housings, i.e. by connecting the grounding contact.

e  Safety requirements are not fulfilled unless this equipment is connected to a wall socket outlet with a protective earth (PE)

contact.
e  The power cord used to connect this equipment must be HAR marked and fitted with an IEC320 connector and an ASTA

approved moulded plug.
e There are no user serviceable parts in this equipment. All servicing and repair tasks must be undertaken by qualified service

personnel.
e  Isolation from mains power is achieved by the removal of the main power cord.

2. Getting Started

This section will describe how to make the physical connections between LanBand and the other system devices, and install the Patapsco management
application, DbManager.

© 2012 Patapsco Designs Ltd
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2.1. Rack Mounting Instructions

The Rack Mounting Kit is comprised of the following:

All Patapsco units can be mounted in a standard 19" rack housing. To allow units to fit info a 19" rack, a Rack Mounting Kit must be purchased for the unit
(s). There are various rack mounting options depending on the size of the unit ordered. The following guide will explain how to use the Rack Mounting Kit

with Patapsco units.

1. Remove the four short screws near the front or rear panel on the left and right hand sides of the Patapsco unit. The unit can be mounted with the front

Photo Description Quantity
‘ L-Bracket 2
d Long Patapsco case screw 4
b Cage Nut 4
° washer 4
ﬂ Rack Mount Screw 4

panel facing forward or with the ports facing forward as required.

2. Fit one of the L-Brackets to the side of the unit. The four small fixing holes allow the unit to protrude forward or sit further back depending on the desired

position of the unit. The bracket may also face forwards or backwards depending on the desired position of the unit.

3. Fixthe L-Bracket in place using the Long Patapsco case screws.

4. Fix the second L-Bracket to the other side of the case in the same way.

5. Put the Rack Mount screws through the Rack Mount washers.

6. Offer the unit up to the rack and fix it in place using the Rack Mount Screws and Rack Mount cage nuts.

2.2. Accessories

The following accessories are supplied with all Patapsco units:

ltem

Description

DbManager CD

Installable DbManager application, technical documents and manuals

Controller Cable

Cable Spec
Management cable. Connects to RJ12 DB9S
LanBand'sTerminal port Pin Function Pin
1 Rx 3
2 Tx 2
3 Gnd 5

|IEC Mains Cable

Connects LanBand to the mains supply

2.3. Optional Accessories

The following items can be ordered from Patapsco, or will be supplied with some units depending on the nature of the device.

ISDN Cables -

Rack Mounting Kit -

Cables to connect the Patapsco device to a CPE or network. Please see the full manual for cable specs on all

Patapsco cables

All Patapsco units can be monuted in a 19" rack using this kit

© 2012 Patapsco Designs Ltd
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2.4. Making Connections

First, connect the ISDN cables to LanBand followed by the Terminal Port management cable (if required), LAN Port cable and lastly the Mains cable. If the
unit has a DC power supply connection, use the screw terminals to connect the DC power source.

&4 Warning: The -48VDC power terminals are marked OV, -48VY, and GND. Patapsco -48VDC products are designed for use
with negative voltage DC supplies, and therefore expect the positive voltage to be connected to the OV terminal, and the
negative connected to -48VY. Please be sure about the polarity of this connection before connecting power to the terminals.
Units which have a positive +24VDC power source will be marked +24VDC, OV and GND respectively. Please ensure that
the positive connection is made on the +24VDC terminal.

2.5. Installing DbManager

DbManager is required in order to monitor and manage Patapsco devices. Management can be made using the Terminal (serial) port, or using TCP/IP over
a LAN or WAN. DbManager is installed using the CD provided with Patapsco equipment.

1. Insert the DbManager Installation Disk into the drive of the PC which will be used for management of LanBand.
2. InstallShield Wizard will start up. Follow the steps to install DbManager.
3. Serial Number — Enter the Serial Number on the case of the DbMgr Disk.

i b

1]
“=" Info: DbManager is supplied as a 'Lite' version by default. This allows configuration and monitoring of devices, but only allows
configuration of a single device node and a single user account. To use DbManager in 'Lite' mode, do not enter a serial
number during installation. Please see the full DbManager User Manual for more information on configuring and using

DbManager.

L
—*_ Warning: If an older version of DbManager is already installed on the management PC, it is necessary to update to the
version supplied on the new DbManager CD. This can be done by consulting the ‘Upgrade’ folder on the DbManager CD. The
‘readme.txt’ file explains how to upgrade to the new DbManager without reinstalling the program.

3. Contiguring LanBand

Follow these steps to connect to LanBand with DbManager and configure the unit for use.

Configuration of LanBand is caried out by setting up DbManager to make a management connection, and then setting up the elements of LanBand in this

order:
Device Settings -

Clock Sources -

ISDN Ports -

Link Configuration -

Call Routing -

The unit-specific settings of the LanBand such as the IP Address and Identifier

configure which interface LanBand is to take synchronisation clock from or network, or
recovered clock from another LanBand

Each ISDN port can be individually configured with the correct settings to interface with another
device or network

Configure setftings to carry ISDN channels across a PSN between LanBand units

Configure routes for the traffic LanBand will pass between connected devices and networks

© 2012 Patapsco Designs Ltd
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3.1. Connecting to LanBand

1. Start up the DbManager Application
2. Login as Super User (no password required)
3. Four windows will be displayed:

[ Cpevices =T |
DB DbMgr Default E|‘
Mdp A network map showing Nodes and Links between Patapsco devices

Terminal A view of the communications between DbMgr and LanBand

Event HiS‘l'Ol'y All events which occur while connected to LanBand

Outsta nding Events Current events

4. Select View > Properties > Terminal from the DbMgr toolbar.

5. Choose the COM port which is in use. Leave the Serial Port Rate at the default setting of 19200bps. Click OK.

6. Select the Devices in World window and double click the Device node

7. The Connected to Device window should appear, showing the front and rear panels of LanBand. If it does not, check the COM port settings and re-try

L
—*_ Warning: If management via the Terminal port is not possible, it could be that the management PC has another application
running which uses the COM ports of the PC. Even when some programs which use the COM ports are closed down, other
programs cannot access the COM ports. Rebooting the PC is required in order to release the COM ports so that DbManager
can use them.

If the PC and LanBand are connected to the same LAN, management is possible using TCP/IP. All Patapsco products use the default IP settings:

IP Address 192.168.0.1
Subnet Mask 255.255.0.0
Gateway 0.0.0.0

To configure DbManager to access LanBand using TCP/IP, please follow these steps:

1. Select View > Properties > Terminal > Device |IP Addresses from the DbMgr toolbar
2.192.168.0.1 should already be configured. If using another IP address, add it to the list using the Add button
3. Click OK » OK

4. Select the Devices in World window and double click the Device node

5. The Connected to Device window should appear, showing the front and rear panels of LanBand

The Device node can be made to connect to other IP addresses configured in the Device IP Addresses list by right-clicking the node, selecting

Properties and choosing an IP address from the IP List.

Y Info: TCP/IP management requires TCP port 3001 (dec) to be open between the management PC and LanBand. Any switches,
hubs or routers must be configured to allow communication on this port in order to manage LanBand via TCP/IP.

© 2012 Patapsco Designs Ltd



Configuring LanBand 7

A successful management connection will open up the Connected to Device window:

l=F

PKT S PKI3

3.2. Notes on configuring LanBand

v Uploading

Changes to config can be made on each window and saved using the OK key when exiting each window. When happy with the
configuration, it must be uploaded to LanBand for the new settings to come info effect.

To upload, go to File > Upload and wait until the progress bar completes.

L1 Saving Files

Configuration files can be saved in order to backup seftings or copy seftings across to another unit. Once configuration has been
uploaded, go to File > Save File and choose a location to save the file to. The file extension of any saved config files is .dbc

1 Loading Files

Once connected to a unit, an existing configuration file can be loaded to the device. Go to File > Open File and navigate to the
saved file. Click Open. Now the file must be uploaded to LanBand. Go to File > Upload and wait until the progress bar
completes.

L
—* Warning: When loading existing configuration files to a unit, please ensure that the correct configuration files are used for the
unit fype in use. LanBand configuration files are not compatible with other Patapsco platforms.

3.3. Device Settings

This menu controls unit-specific features of the LanBand such as the IP Address, Identifier, Serial Number, Configuration Number, Time & Date and Event
Reporting. These features are all fully explained in the LanBand User Manual on the DbManager Installation Disk.

3.4. Clock Sources

LanBand must be configured to either receive clock from an ISDN interface , a connection to another LanBand or generate clock internally. Different
priorities can be set for each port, so if one port is unavailable, LanBand will clock from the next available port in the Clock Source hierarchy.

1. Select Clock Sources from the Terminal port menu.

2. Enter a digit to mark the priority of each ISDN port and the internal clock. O will denote the highest priority Clock Source and 19 will denote the lowest.
Ports which are not to be used for clocking can have their values left at 19.

3. Click OK to save the sefting.

© 2012 Patapsco Designs Ltd



8 LanBand Quickstart Guide

* . Warning: Clock Sources must be configured correctly to ensure error-free operation when LanBand is connected to any other
clock-locked system or network. Please consult the full LanBand manual if unsure how to configure Clock Sources.

3.5. PRI Ports

There are two LEDs for each PRI port, and the LED states are as follows:

Top LED on - Layer 1 and 2 established
Top LED flashing - Layer 1 established, trying to synchronize with Layer 2
Bottom LED on - Calls active on interface

1. Click on an enabled PRI port.

2. The configuration settings for the port are displayed.
3. Configure the settings as required for the port.

4. Click OK to save the settings.

3.6. BRI Ports

There are two LEDs for each BRI port, and the LED states are as follows:

Top LED on - Calls active on B channel number 1
Bottom LED on - Calls active on B channel number 2
LEDs off - No calls active on interface

1. Click on an enabled BRI port.

2. The configuration settings for the port are displayed.
3. Configure the settings as required for the port

4. Click OK to save the settings.

“’Note: Each block of 4 BRI ports can be switched to TE mode (if the switchable BRI option is taken). Switching a single port o
TE mode will change the whole block to TE. The sefting must then be uploaded, LanBand must be rebooted and a crossover
cable must be used in order to use the port in TE mode.

3.7. Configuring Routing Profiles

It is strongly recommended that you draw a simple diagram showing the LanBand, its ISDN ports in use, the DDI numbers, and any local devices and the
number ranges used to access them. An example is shown below.

T e,
.ﬂ.-_x 7 B 1‘(._\ —
( : B
PSTN |: e LAMN 2
Bl \ - gl ISDN Fhone
S \ PKT 1 BRI 1
LanBand 1 LanBand 2

This example requires that the LanBands route calls as follows:

1. Route calls from the PSTN to the ISDN Phone
2. Route calls from the ISDN Phone to the PSTN

All of these actions can be catered for using Call Routing Profiles. A Call Routing Profile is used to direct traffic from one port or group of ports to another,
orto a Logical Link. A Routing Profile has many options to control how calls are routed, but in this case and in most applications the Routing Profile will
consists of the following elements:

© 2012 Patapsco Designs Ltd
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Name, Source, Destination
Click on the Terminal port and select Call Routing from the Drop-Down menu to configure routing profiles for LanBand.

1. The Call Routing Profiles List is displayed. This will show all Routing Profile details when they are configured.

2. Select Add Profile and choose Add Routing Profile.

3. Name the profile and tick the Enable check-box.

4. Move the SOURCE PORTS radio button to Select and enter a source forincoming calls. A source can be designated by entering a port number, port
and channel number or by using a Group of ports and/or channels:

To use a port: Enter the port number (e.g. 21 for PRI 21, 1 for BRI 1)

To use a port and Enter the port number followed by a full stop and then the channel number (e.g. 21.1 for PRI 21 channel 1, 1.1 for BRI 1
channel: channel 1)

To use a Group: Configure a group and select it from the Drop-Down menu (see 5.2 for instructions on configuring a group)

To use a Logical Link: Enter the Logical Link number (101 for Logical Link 101, 164 for Logical Link 164)

5. Move the DESTINATION PORTS radio button to Select, and enter a destination for calls in the same way as the SOURCE PORTS
6. Select the Incoming Numbers tab to choose numbers which Liberator will use to route the calls.

'~ Note: If no Incoming Numbers are configured (*/*), LanBand will route all calls received on the Source ports to the Destination
ports, regardless of the DDI, CLI or SubAddress numbers of the call.

7. The DDI Listing defaults to */* which represents any number and any SubAddress (Number/SubAddress).

8. Double click the */* to edit the number values. An entry of *1284/* would route any call with a DDI ending in 1234 with any SubAddress. Right-clicking
an existing entry will present more options.

9. Enter a CLI value if required. This is entered in the same way as the DDI. The default value; * will route calls with any CLI.

"’ Note: More routing options may be used to configure complex routing profiles. These are all explained in the LanBand manual
on the DbManager installation disk.

10. Click OK on the two active windows and the new routing profile will appear in the Call Routing Profiles List.
11. Click Exit to return to the Connected to Device window.

Prioritizing Routing Profiles

The Call Routing Profiles List shows all configured Call Routing Profiles in order of priority. These priorities can be rearranged to allow diverse routing
possibilities. When LanBand receives a call, it will check each profile in order from the top of the list for any routing parameters matching those of the call. It
will route the call based on the first matching profile.

1. Select Call Routing from the Terminal port Drop-Down menu.

2. All configured routing profiles are displayed.

3. Right click on a profile in the Type column to display options. The profile can be promoted or demoted in the priority list. There are also options to edit
and delete the profile.

This table shows the profiles which would be required to carry out the call routing shown in the diagram above:

Profile Number | Profile Name Source |Primary Destination | DDIs
0 PSTN to ISDN Phone | 21 101 e
1 ISDN Phone to PSTN | 101 21 e

LanBand 1 will route any calls from the PSTN to LanBand 2 via its Logical Link 101, and any calls from LanBand 2 to the PSTN. LanBand 2 will have the
following routing configuration:

© 2012 Patapsco Designs Ltd
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Profile Number |Profile Name Source |Primary Destination | DDIs
0 ISDN Phone to PSTN | 101 1 A
1 PSTN to ISDN Phone |1 101 e

Calls can now be passed between the two LanBands.

3.8. Link Configuration

The Link Configuration option is used to configure Logical Links between LanBand units. Each Logical Link can carry up to 32 ISDN channels.

Packet Addresses
Local |

|1n.1.1.1a1

Remate

1. Click on Link Configuration

2. Select the first Logical Link; LL101

3. Tick the Enable tickbox

3. Enter the IP address of the remote LanBand

v Note: Each Logical Link can be configured with many seftings for transport across a Packet Switched Network. All of these
options are described in the LanBand User Manual. The above seftings are all that is required to get a Logical Link running
initially. A pair of LanBands working in a system should have identical Logical Link settings in order to pass traffic across a PSN.

3.9. Using Groups
When more than one port needs to be configured as a source or destination for calls, a Group of ports can be set.

1. Select Add Group from the Add Routing Profile screen.
2. The Group Configuration screen is displayed.
3. Name the Group you wish to configure.

i b

1]
“= Note: The names of any Routing Profiles, Groups and Identifiers must not contain the following characters: < > ~

4. Use the All and None buttons to add blocks of PRI and BRI ports to the Group, or select individual channels from each port by using the tick-boxes.
5. Click OK to save the group.

6. The new Group will now appearin the SOURCE and DESTINATION drop-down menus. Select this Group from the drop-down to use it in a Call
Routing Profile.

3.10. Finishing Configuration

"~ Note: Please remember fo Upload when configuration of LanBand is complete. To upload, go to File 2 Upload and wait
until the progress bar completes.

© 2012 Patapsco Designs Ltd



Configuring LanBand 11

3.11. More Resources

All Patapsco products and the DbManager application have their own User Manuals which can be found in the 'Documents & Manuals' folder on the

DbManager installation disk. Please consult these manuals for more detailed information on any aspect of using Patapsco products. All documentation can
also be obtained by registering at the Patapsco website:

http://www.patapsco.co.uk/Top Level/Logln Register.asp

For help with a specific problem, please click on the On-Line Help icon on the website, or email a request to support@patapsco.co.uk

© 2012 Patapsco Designs Ltd
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